summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-05-11 22:15:02 -0400
committerSimo Sorce <simo@redhat.com>2012-10-25 15:40:24 -0400
commitd5976d3c7aea2f5e6626028fa6a2848f2a946371 (patch)
tree9d37cfcc0801e73e3f2b1b10613ece5f4cf97fbf /proxy/Makefile.am
parent9230a19840d9ed2f750ae22d9f1f91fb6d4ffb5a (diff)
downloadgss-proxy-d5976d3c7aea2f5e6626028fa6a2848f2a946371.tar.gz
gss-proxy-d5976d3c7aea2f5e6626028fa6a2848f2a946371.tar.xz
gss-proxy-d5976d3c7aea2f5e6626028fa6a2848f2a946371.zip
Build mechglue as a plugin
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 48a787d..11e780e 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -49,6 +49,9 @@ sbin_PROGRAMS = \
check_PROGRAMS = \
cli_srv_comm
+gssplib_LTLIBRARIES = \
+ proxymech.la
+
dist_noinst_SCRIPTS =
dist_noinst_DATA =
@@ -143,6 +146,16 @@ gssproxy_SOURCES = \
src/gp_rpc_wrap_size_limit.c \
src/gssproxy.c
+proxymech_la_SOURCES = \
+ src/gp_conv.c \
+ $(GP_RPCGEN_OBJ) \
+ $(GP_MECHGLUE_OBJ)
+proxymech_la_CFLAGS = \
+ $(AM_FLAGS)
+proxymech_la_LDFLAGS = \
+ -avoid-version \
+ -module
+
cli_srv_comm_SOURCES = \
src/gp_conv.c \
src/gp_debug.c \