summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-05-17 00:43:55 -0400
committerSimo Sorce <simo@redhat.com>2012-10-25 15:48:12 -0400
commitc9fb982ac154433f8ca48fcd1ea2527e09f8ad42 (patch)
tree9b82d6f25d7a072c70320926f7cad4d83d03cd6e /proxy/Makefile.am
parentf0102ece0a0dd6545d0547af55c6ee79f77c79dd (diff)
downloadgss-proxy-c9fb982ac154433f8ca48fcd1ea2527e09f8ad42.tar.gz
gss-proxy-c9fb982ac154433f8ca48fcd1ea2527e09f8ad42.tar.xz
gss-proxy-c9fb982ac154433f8ca48fcd1ea2527e09f8ad42.zip
Add initialization code
For now return fixed list of mechanisms. Later on we can try to fetch this list from the proxy. Also split RPC client code from actual plugin
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 11e780e..4274cef 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -85,7 +85,7 @@ if BUILD_SELINUX
endif
GP_RPCGEN_OBJ = rpcgen/gp_rpc_xdr.c rpcgen/gss_proxy_xdr.c
-GP_MECHGLUE_OBJ = \
+GP_RPCCLI_OBJ = \
src/client/gpm_display_status.c \
src/client/gpm_accept_sec_context.c \
src/client/gpm_release_handle.c \
@@ -100,6 +100,8 @@ GP_MECHGLUE_OBJ = \
src/client/gpm_unwrap.c \
src/client/gpm_wrap_size_limit.c \
src/client/gpm_common.c
+GP_MECHGLUE_OBJ = \
+ src/mechglue/gss_plugin.c
dist_noinst_HEADERS = \
rpcgen/gp_rpc.h \
@@ -149,6 +151,7 @@ gssproxy_SOURCES = \
proxymech_la_SOURCES = \
src/gp_conv.c \
$(GP_RPCGEN_OBJ) \
+ $(GP_RPCCLI_OBJ) \
$(GP_MECHGLUE_OBJ)
proxymech_la_CFLAGS = \
$(AM_FLAGS)
@@ -160,7 +163,7 @@ cli_srv_comm_SOURCES = \
src/gp_conv.c \
src/gp_debug.c \
$(GP_RPCGEN_OBJ) \
- $(GP_MECHGLUE_OBJ) \
+ $(GP_RPCCLI_OBJ) \
tests/cli_srv_comm.c
gssproxy_LDADD = \