summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-07-31 18:15:12 -0400
committerSimo Sorce <simo@redhat.com>2012-08-31 16:26:38 -0400
commit1919bf9c7a8c0995e4a4bc0483732084b3b5f241 (patch)
tree9e0f0ce6b073ef01874d4af682d8d191c382c2d0 /proxy/Makefile.am
parent798883aad353add2f9830e6e2c993ac804411639 (diff)
downloadgss-proxy-1919bf9c7a8c0995e4a4bc0483732084b3b5f241.tar.gz
gss-proxy-1919bf9c7a8c0995e4a4bc0483732084b3b5f241.tar.xz
gss-proxy-1919bf9c7a8c0995e4a4bc0483732084b3b5f241.zip
Move client lib files in their own directory
Make space for the actual mechglue plugin interface. The mechglue interface will use the client library to communicate with the gss-proxy but will reimplement all GSSAPI SPI as wrappers in order to properly handle fallbacks to local mechanism and other input/output transformations.
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 15f29e2..ec6eb50 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -83,21 +83,21 @@ endif
GP_RPCGEN_OBJ = rpcgen/gp_rpc_xdr.c rpcgen/gss_proxy_xdr.c
GP_MECHGLUE_OBJ = \
- src/mechglue/gpm_display_status.c \
- src/mechglue/gpm_accept_sec_context.c \
- src/mechglue/gpm_release_handle.c \
- src/mechglue/gpm_acquire_cred.c \
- src/mechglue/gpm_indicate_mechs.c \
- src/mechglue/gpm_import_and_canon_name.c \
- src/mechglue/gpm_init_sec_context.c \
- src/mechglue/gpm_common.c
+ src/client/gpm_display_status.c \
+ src/client/gpm_accept_sec_context.c \
+ src/client/gpm_release_handle.c \
+ src/client/gpm_acquire_cred.c \
+ src/client/gpm_indicate_mechs.c \
+ src/client/gpm_import_and_canon_name.c \
+ src/client/gpm_init_sec_context.c \
+ src/client/gpm_common.c
dist_noinst_HEADERS = \
rpcgen/gp_rpc.h \
rpcgen/gss_proxy.h \
src/gp_rpc_process.h \
src/gp_proxy.h \
- src/mechglue/gssapi_gpm.h \
+ src/client/gssapi_gpm.h \
src/gp_common.h \
src/gp_log.h \
src/gp_creds.h \