summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2013-07-04 16:37:12 -0400
committerSimo Sorce <simo@redhat.com>2013-07-18 22:37:25 -0400
commit994d9639caeec0164134e3bd6c16512defe93021 (patch)
treeb7709922d0159a6250bb59b23dcf8a14af752cce /Makefile.am
parent399c16829ceb8dad8f3f6e25e626212e4fca332e (diff)
downloadgss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.tar.gz
gss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.tar.xz
gss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.zip
NTLM Crypto functions
Adds crypto function helpers needed by NTLM authentication
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cb75e1e..798841b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,15 +64,19 @@ AM_CPPFLAGS = \
-DSYSCONFDIR=\"$(sysconfdir)\" \
-DLOCALEDIR=\"$(localedir)\"
-EXTRA_DIST = build/config.rpath
+#EXTRA_DIST = build/config.rpath
-GSS_NTLM_LIBS = $(GSSAPI_LIBS)
+GN_MECHGLUE_LIBS = $(GSSAPI_LIBS) $(CRYPTO_LIBS)
GN_MECHGLUE_OBJ = \
+ src/crypto.c \
+ src/ntlm_crypto.c \
src/ntlm.c \
src/gss_ntlmssp.c
dist_noinst_HEADERS = \
+ src/crypto.h \
+ src/ntlm_common.h \
src/ntlm.h \
src/gss_ntlmssp.h
@@ -85,6 +89,7 @@ gssntlmssp_la_SOURCES = \
gssntlmssp_la_CFLAGS = \
$(AM_FLAGS)
gssntlmssp_la_LDFLAGS = \
+ $(GN_MECHGLUE_LIBS) \
-avoid-version \
-module