summaryrefslogtreecommitdiffstats
path: root/ipapython/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'ipapython/setup.py')
-rwxr-xr-xipapython/setup.py41
1 files changed, 41 insertions, 0 deletions
diff --git a/ipapython/setup.py b/ipapython/setup.py
new file mode 100755
index 000000000..81e032b23
--- /dev/null
+++ b/ipapython/setup.py
@@ -0,0 +1,41 @@
+#!/usr/bin/python2
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+"""FreeIPA python support library
+
+FreeIPA is a server for identity, policy, and audit.
+"""
+import os
+import sys
+
+# include ../ for ipasetup.py
+sys.path.append(os.path.dirname(os.path.dirname(os.path.abspath(__file__))))
+
+from ipasetup import ipasetup # noqa: E402
+
+ipasetup(
+ name="ipapython",
+ doc=__doc__,
+ package_dir={'ipapython': ''},
+ packages=[
+ "ipapython",
+ "ipapython.dnssec",
+ "ipapython.secrets",
+ "ipapython.install"
+ ],
+)