summaryrefslogtreecommitdiffstats
path: root/daemons/dnssec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/dnssec/Makefile.am')
-rw-r--r--daemons/dnssec/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/daemons/dnssec/Makefile.am b/daemons/dnssec/Makefile.am
new file mode 100644
index 000000000..37a0dcf51
--- /dev/null
+++ b/daemons/dnssec/Makefile.am
@@ -0,0 +1,32 @@
+# This file will be processed with automake-1.7 to create Makefile.in
+#
+AUTOMAKE_OPTIONS = 1.7
+
+appdir = $(libexecdir)/ipa/
+dist_app_SCRIPTS = \
+ ipa-dnskeysyncd \
+ ipa-dnskeysync-replica \
+ ipa-ods-exporter
+
+dist_noinst_DATA = \
+ ipa-dnskeysyncd.service.in \
+ ipa-ods-exporter.service.in \
+ ipa-ods-exporter.socket.in
+
+systemdsystemunit_DATA = \
+ ipa-dnskeysyncd.service \
+ ipa-ods-exporter.service \
+ ipa-ods-exporter.socket
+
+CLEANFILES = $(systemdsystemunit_DATA)
+
+%: %.in Makefile
+ sed \
+ -e 's|@libexecdir[@]|$(libexecdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@sysconfenvdir[@]|$(sysconfenvdir)|g' \
+ '$(srcdir)/$@.in' >$@
+
+dnssecconfdir = $(IPA_SYSCONF_DIR)/dnssec
+install-data-hook:
+ $(INSTALL) -d -m 755 $(DESTDIR)$(dnssecconfdir)