summaryrefslogtreecommitdiffstats
path: root/ipaserver/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-10-27 14:04:58 +0200
committerMartin Basti <mbasti@redhat.com>2016-11-16 22:58:39 +0100
commit8346e1b067483d4d836627a267805bbe8d6e7efa (patch)
treee4206cfe30c39cfcc7aebfa8937ea1620c623822 /ipaserver/setup.py
parent6ca96b3db03d4f3c5dbf465ca3d36bd563771c47 (diff)
downloadfreeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.tar.gz
freeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.tar.xz
freeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.zip
Add install requirements to Python packages
https://fedorahosted.org/freeipa/ticket/6468 Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'ipaserver/setup.py')
-rwxr-xr-xipaserver/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/ipaserver/setup.py b/ipaserver/setup.py
index 8ce2970f2..5c38843b4 100755
--- a/ipaserver/setup.py
+++ b/ipaserver/setup.py
@@ -43,4 +43,30 @@ if __name__ == '__main__':
'ipaserver.install.plugins',
'ipaserver.install.server',
],
+ install_requires=[
+ "cryptography",
+ "dbus-python",
+ "dnspython",
+ "dogtag-pki",
+ "ipaclient",
+ "ipalib",
+ "ipaplatform",
+ "ipapython",
+ "lxml",
+ "netaddr",
+ "memcache",
+ "pyasn1",
+ "pyldap",
+ "python-nss",
+ "six",
+ # not available on PyPI
+ # "python-libipa_hbac",
+ # "python-sss",
+ # "python-sss-murmur",
+ # "python-SSSDConfig",
+ # "samba-python",
+ ],
+ setup_requires=[
+ "wheel",
+ ],
)