summaryrefslogtreecommitdiffstats
path: root/ipaserver/setup.py
diff options
context:
space:
mode:
authorJan Cholasta <jcholast@redhat.com>2016-08-24 12:52:08 +0200
committerDavid Kupka <dkupka@redhat.com>2016-10-24 14:11:08 +0200
commit0b91735c79a0ba577f9540e946180760a97913a4 (patch)
treef615b39cdc1277e94718ba42cd72b8b6dc4ebe05 /ipaserver/setup.py
parent0d370a959b6b55f995661b2febe55c379065c4d9 (diff)
downloadfreeipa-0b91735c79a0ba577f9540e946180760a97913a4.tar.gz
freeipa-0b91735c79a0ba577f9540e946180760a97913a4.tar.xz
freeipa-0b91735c79a0ba577f9540e946180760a97913a4.zip
ipaserver: remove ipalib import from setup.py
Instead of importing ipalib to get IPA version string, create setup.py from a template and have the version string automatically filled in. This makes it possible to build the ipaserver package without having to have ipalib dependencies installed. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Petr Spacek <pspacek@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'ipaserver/setup.py')
-rwxr-xr-xipaserver/setup.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/ipaserver/setup.py b/ipaserver/setup.py
index 33b1c51df..73afb7096 100755
--- a/ipaserver/setup.py
+++ b/ipaserver/setup.py
@@ -28,14 +28,12 @@ import sys
# include ../ for ipasetup.py and ipalib
sys.path.append(os.path.dirname(os.path.dirname(os.path.abspath(__file__))))
-import ipalib # noqa: E402
from ipasetup import ipasetup # noqa: E402
ipasetup(
name='freeipa',
doc=__doc__,
- version=ipalib.__version__,
package_dir={'ipaserver': ''},
packages=[
'ipaserver',