summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2014-11-17 15:19:57 -0500
committerSimo Sorce <simo@redhat.com>2014-11-20 10:34:27 -0500
commitd808403bb0bb262f79b4695ab854ab770e05e7aa (patch)
tree7605ca7d16e3f6a773aa52aea2241d19d8a0c6c3 /ipa-client/Makefile.am
parent9a3342a1f8e03672f311eb269e2039cb7a045cde (diff)
downloadfreeipa-d808403bb0bb262f79b4695ab854ab770e05e7aa.tar.gz
freeipa-d808403bb0bb262f79b4695ab854ab770e05e7aa.tar.xz
freeipa-d808403bb0bb262f79b4695ab854ab770e05e7aa.zip
Use asn1c helpers to encode/decode the getkeytab controlasn1c-indented
Replaces manual encoding with automatically generated code. Fixes: https://fedorahosted.org/freeipa/ticket/4718 https://fedorahosted.org/freeipa/ticket/4728
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 2df175e53..b9c7020f3 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -14,11 +14,13 @@ export AM_CFLAGS
KRB5_UTIL_DIR=../util
KRB5_UTIL_SRCS=$(KRB5_UTIL_DIR)/ipa_krb5.c
+ASN1_UTIL_DIR=../asn1
AM_CPPFLAGS = \
-I. \
-I$(srcdir) \
-I$(KRB5_UTIL_DIR) \
+ -I$(ASN1_UTIL_DIR) \
-DPREFIX=\""$(prefix)"\" \
-DBINDIR=\""$(bindir)"\" \
-DLIBDIR=\""$(libdir)"\" \
@@ -45,6 +47,7 @@ ipa_getkeytab_SOURCES = \
$(NULL)
ipa_getkeytab_LDADD = \
+ ../asn1/libipaasn1.la \
$(KRB5_LIBS) \
$(OPENLDAP_LIBS) \
$(SASL_LIBS) \
@@ -80,6 +83,7 @@ ipa_join_LDADD = \
$(NULL)
SUBDIRS = \
+ ../asn1 \
ipaclient \
ipa-install \
man \