summaryrefslogtreecommitdiffstats
path: root/init/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-03 11:03:03 +0100
committerMartin Babinsky <mbabinsk@redhat.com>2016-11-09 13:08:32 +0100
commit288d624336d502a7df9856cdc2f6543b6e7c0b79 (patch)
tree963009cf0594db73bba8c58ae6510f5be74be9c6 /init/Makefile.am
parenta027bf739848371fa91b5ba9766e031c9003d322 (diff)
downloadfreeipa-288d624336d502a7df9856cdc2f6543b6e7c0b79.tar.gz
freeipa-288d624336d502a7df9856cdc2f6543b6e7c0b79.tar.xz
freeipa-288d624336d502a7df9856cdc2f6543b6e7c0b79.zip
Build: integrate init and init/systemd into build system
At the same time, I've renamed tmpfilesd config file to static name "ipa.conf" instead of using package-specific name. It had no purpose and just complicated build and packaging. Variable substitution into configuration has to be done in Makefile and not in Autoconf as documented in: Autoconf v2.69 manual chapter 4.8.2 Installation Directory Variables: ... Most of these variables have values that rely on prefix or exec_prefix. ... Similarly, you should not rely on AC_CONFIG_FILES to replace bindir and friends in your shell scripts and other files; instead, let make manage their replacement. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'init/Makefile.am')
-rw-r--r--init/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/init/Makefile.am b/init/Makefile.am
new file mode 100644
index 000000000..47f844ac1
--- /dev/null
+++ b/init/Makefile.am
@@ -0,0 +1,20 @@
+# This file will be processed with automake-1.7 to create Makefile.in
+#
+AUTOMAKE_OPTIONS = 1.7
+
+SUBDIRS = systemd tmpfilesd
+
+dist_sysconfenv_DATA = \
+ ipa-dnskeysyncd \
+ ipa-ods-exporter
+
+nodist_sysconfenv_DATA = \
+ ipa_memcached
+
+CLEANFILES = $(nodist_sysconfenv_DATA)
+
+dist_noinst_DATA = \
+ ipa_memcached.in
+
+%: %.in Makefile
+ sed -e 's|@localstatedir[@]|$(localstatedir)|g' '$(srcdir)/$@.in' >$@