summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2015-02-28 20:55:12 -0500
committerSimo Sorce <simo@redhat.com>2015-03-04 11:22:29 -0500
commit8a4473d294f0bf521eb8e5ae9ad36a6876b42117 (patch)
treef5b4a1351efc339b5b5214f2fdde8d2b01635c05 /setup.py
downloadcustodia-8a4473d294f0bf521eb8e5ae9ad36a6876b42117.tar.gz
custodia-8a4473d294f0bf521eb8e5ae9ad36a6876b42117.tar.xz
custodia-8a4473d294f0bf521eb8e5ae9ad36a6876b42117.zip
Initial Commit
Signed-off-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..692523a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/python
+#
+# Copyright (C) 2015 Custodia project Contributors, for licensee see COPYING
+
+from distutils.core import setup
+
+setup(
+ name = 'custodia',
+ version = '0.0.1',
+ license = 'GPLv3+',
+ maintainer = 'Custodia project Contributors',
+ maintainer_email = 'simo@redhat.com',
+ url='https://github.com/simo5/custodia',
+ packages = ['custodia', 'custodia.tools'],
+ data_files = [('share/man/man7', ["man/custodia.7"]),
+ ('share/doc/custodia', ['COPYING', 'README']),
+ ('share/doc/custodia/examples', ['examples/custodia.conf']),
+ ],
+ scripts = ['custodia/custodia']
+)
+