summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fc796eddb..3b3c0fb51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,7 +122,8 @@ if HAVE_CHECK
util-tests \
debug-tests \
ipa_hbac-tests \
- sss_idmap-tests
+ sss_idmap-tests \
+ pac_responder-tests
endif
check_PROGRAMS = \
@@ -599,6 +600,7 @@ endif
sssd_pac_SOURCES = \
src/responder/pac/pacsrv.c \
src/responder/pac/pacsrv_cmd.c \
+ src/responder/pac/pacsrv_utils.c \
$(SSSD_UTIL_OBJ) \
$(SSSD_RESPONDER_OBJ)
sssd_pac_CFLAGS = \
@@ -608,6 +610,7 @@ sssd_pac_LDADD = \
$(NDR_KRB5PAC_LIBS) \
$(TDB_LIBS) \
$(SSSD_LIBS) \
+ libsss_idmap.la \
libsss_util.la
sssd_be_SOURCES = \
@@ -994,6 +997,18 @@ sss_idmap_tests_LDADD = \
libsss_test_common.la \
libsss_idmap.la
+pac_responder_tests_SOURCES = \
+ src/tests/pac_responder-tests.c \
+ src/responder/pac/pacsrv_utils.c
+pac_responder_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NDR_KRB5PAC_CFLAGS) \
+ $(CHECK_CFLAGS)
+pac_responder_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(TALLOC_LIBS) \
+ libsss_debug.la \
+ libsss_test_common.la
endif
stress_tests_SOURCES = \