summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2bcb71457..0cc98734a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ if HAVE_CMOCKA
test-io \
sss_nss_idmap-tests \
test-io \
- dyndns-tests
+ dyndns-tests \
+ fqnames-tests
endif
check_PROGRAMS = \
@@ -1305,6 +1306,16 @@ dyndns_tests_LDADD = \
$(CARES_LIBS) \
$(CMOCKA_LIBS) \
libsss_util.la
+
+fqnames_tests_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_fqnames.c
+fqnames_tests_CFLAGS = \
+ $(AM_CFLAGS)
+fqnames_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ libsss_util.la
+
endif
noinst_PROGRAMS = pam_test_client