summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2015-02-10 16:14:59 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-02-25 08:38:31 +0100
commitdc4c30bae512c0b45ff925d9e998337f8fe97e94 (patch)
tree41fe6283dde854d801785193d0af8971b1a91549 /configure.ac
parente4796d5ed8e08be7f3767e12753389b18a2ce9f0 (diff)
downloadsssd-dc4c30bae512c0b45ff925d9e998337f8fe97e94.tar.gz
sssd-dc4c30bae512c0b45ff925d9e998337f8fe97e94.tar.xz
sssd-dc4c30bae512c0b45ff925d9e998337f8fe97e94.zip
BUILD: Use python-config for detection *FLAGS
The script python-config was not available in older versions of python. This patch simplify detection of python CFLAGS and LDFLAGS and increase minimal required version of python to 2.6 Reviewed-by: Stephen Gallagher <sgallagh@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cdbe6f9bf..f72e44852 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,11 +248,13 @@ AM_CONDITIONAL([HAVE_MANPAGES], [test "x$HAVE_MANPAGES" != "x"])
AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
if test x$HAVE_PYTHON_BINDINGS != x; then
- AM_PATH_PYTHON([2.4])
+ AM_PATH_PYTHON([2.6])
+ AM_PYTHON_CONFIG([python])
AM_CHECK_PYTHON_HEADERS([],
AC_MSG_ERROR([Could not find python headers]))
- AM_PYTHON_CONFIG
AM_CHECK_PYTHON_COMPAT
+ AC_SUBST([PYTHON_CFLAGS])
+ AC_SUBST([PYTHON_LIBS])
fi
if test x$HAVE_SELINUX != x; then