summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-11-06 20:54:13 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-11-14 13:33:43 +0100
commit6b01dae732eedee808f32a9cdd4b5656a9f839c4 (patch)
tree0ea3a2cfd099b4ce2e2e0c9f48148f72681d9d2d /configure.ac
parente8ae3af6724164048a85c374ea8045a368a2d34e (diff)
downloadsssd-6b01dae732eedee808f32a9cdd4b5656a9f839c4.tar.gz
sssd-6b01dae732eedee808f32a9cdd4b5656a9f839c4.tar.xz
sssd-6b01dae732eedee808f32a9cdd4b5656a9f839c4.zip
sbus: Check string arguments for valid UTF-8 strings
libdbus abort()s when a string argument is not valid UTF-8. Since the arguments sometimes come from untrusted sources, it's better to check the string validity explicitly. Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe3e137b7..3fe824224 100644
--- a/configure.ac
+++ b/configure.ac
@@ -218,10 +218,19 @@ fi
if test x$has_dbus != xno; then
SAFE_LIBS="$LIBS"
LIBS="$DBUS_LIBS"
+ SAFE_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS $DBUS_CFLAGS"
+
AC_CHECK_FUNC([dbus_watch_get_unix_fd],
AC_DEFINE([HAVE_DBUS_WATCH_GET_UNIX_FD], [1],
[Define if dbus_watch_get_unix_fd exists]))
+ AC_CHECK_TYPES([DBusBasicValue],
+ [],
+ [],
+ [ #include <dbus/dbus.h> ])
+
LIBS="$SAFE_LIBS"
+ CFLAGS=$SAFE_CFLAGS
fi
# work around a bug in cov-build from Coverity