summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2016-03-31 11:17:01 +0200
committerLukas Slebodnik <lslebodn@redhat.com>2016-04-01 09:45:17 +0200
commit5ebdc2391e96cfcc86ebdb8f223e159c00a0d82b (patch)
treefb6de09a29beb201b7fe33ecef926043f08b3cb6 /configure.ac
parentdad416a9b0095e1c423b7da65db7c636fa69e614 (diff)
downloadsssd-5ebdc2391e96cfcc86ebdb8f223e159c00a0d82b.tar.gz
sssd-5ebdc2391e96cfcc86ebdb8f223e159c00a0d82b.tar.xz
sssd-5ebdc2391e96cfcc86ebdb8f223e159c00a0d82b.zip
AUTOMAKE: Force usage of parallel test harness
Parallel test harness[1] is enabled by default with new versions of automake. However, automake on rhel6 (1.11.1-4) still uses serial test harness by default even though it also contains parallel test harness. Downside of serial test is that output of all test are mixed together and is not in separate log files as with parallel test harness. Another problem is slow execution test with valgrind due to missing parallelisation. It's approximately 4-5 minutes slower on machine with 4 CPUs. The automake option parallel-tests is kept for backward-compatibility in new versions of automake, since the parallel test harness is the default there. [1] http://www.gnu.org/software/automake/manual/html_node/Parallel-Test-Harness.html#Parallel-Test-Harness [2] http://www.gnu.org/software/automake/manual/html_node/Serial-Test-Harness.html#Serial-Test-Harness Reviewed-by: Nikolai Kondrashov <Nikolai.Kondrashov@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2c36049ca..b4ba366d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,8 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
-AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign subdir-objects tar-pax])
+AM_INIT_AUTOMAKE([-Wall -Wno-portability foreign subdir-objects tar-pax
+ parallel-tests])
AM_PROG_CC_C_O
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
AC_DISABLE_STATIC