summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2016-03-01 15:35:19 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2016-06-10 18:15:27 +0200
commitc23ea7772113a163139a7b7669303e9e80dc1d09 (patch)
treebc62496f3b1746e855ef0963a133fdd791995dd5 /Makefile.am
parent41291f19dbc5bf14f20729959b852fa605fcc02d (diff)
downloadsssd-c23ea7772113a163139a7b7669303e9e80dc1d09.tar.gz
sssd-c23ea7772113a163139a7b7669303e9e80dc1d09.tar.xz
sssd-c23ea7772113a163139a7b7669303e9e80dc1d09.zip
CONTRIB: Add a systemstap script to measure nested group code performance
When all the dependencies are installed, run the script using systemtap: You'll see an output such as: # stap /usr/share/sssd/systemtap/nested_group_perf.stp ^CTime spent in group sssd_be searches: 600 Time spent in sdap_nested_group_send/recv: 65 ms (ratio: 10.83%) Time spent in zero-level sysdb transactions: 6813 ms (ratio: 1135.50%) Breakdown of sdap_nested_group req (total: 65 ms) sdap_nested_group_process req: 64 sdap_nested_group_process_split req: 22 sdap_nested_group_check_cache: 21 sdap_nested_group_sysdb_search_users: 10 sdap_nested_group_sysdb_search_groups: 9 ldap request breakdown of total 60 sdap_nested_group_deref req: 24 sdap_deref_search_send req 24 processing deref results: 0 sdap_nested_group_lookup_user req: 18 sdap_nested_group_lookup_group req: 0 Time spent refreshing unknown members: 18 Breakdown of results processing (total 6813) Time spent populating nested members: 10 Time spent searching ldb while populating nested members: 5 Time spent saving nested members: 110 Time spent writing to the ldb: 678 ms Please note that since the script is supposed to be used in scenarios such as tracing "id" performance, which typically involve multiple group requests. Therefore, the variables are not zeroed out and you need to interrupt the script manually with Ctrl+C. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9c1ae1ca9..25130b105 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1092,6 +1092,7 @@ dist_systemtap_tap_DATA = \
dist_sssdtapscript_DATA = \
contrib/systemtap/id_perf.stp \
+ contrib/systemtap/nested_group_perf.stp \
$(NULL)
stap_generated_probes.h: $(srcdir)/src/systemtap/sssd_probes.d