summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2016-02-29 13:20:28 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2016-06-10 18:15:27 +0200
commit6dcbfe52d5e64205c0d922f3e89add066b42c496 (patch)
tree17ccc47e89ac2733ee62062c6fbeb8af50179463 /Makefile.am
parentbd93ef2db6d24946ebf98a23fa18d34d45f6b072 (diff)
downloadsssd-6dcbfe52d5e64205c0d922f3e89add066b42c496.tar.gz
sssd-6dcbfe52d5e64205c0d922f3e89add066b42c496.tar.xz
sssd-6dcbfe52d5e64205c0d922f3e89add066b42c496.zip
SYSDB: Add systemtap probes to track sysdb transactions
Actually adds marks for sysdb transactions that receive the transaction nesting level as an argument. The nesting is passed on from probes to marks along with a human-friendly description. The transaction commit is decorated with two probes, before and after. This would allow the caller to distinguish between the time we spend in the transaction (which might be important, because if a transaction is active on an ldb context, even the readers are blocked before the transaction completes) and the time we spend commiting the transaction (which is important because that's when the disk writes occur) The probes would be installed into /usr/share/systemtap/tapset on RHEL and Fedora. This is in line with systemtap's paths which are described in detail in "man 7 stappaths". Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a20f0a52c..3a2bb44f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,6 +81,7 @@ krb5rcachedir = @krb5rcachedir@
sudolibdir = @sudolibpath@
polkitdir = @polkitdir@
pamconfdir = $(sysconfdir)/pam.d
+systemtap_tapdir = @tapset_dir@
UNICODE_LIBS=@UNICODE_LIBS@
@@ -1082,6 +1083,8 @@ SYSTEMTAP_PROBES = \
$(srcdir)/src/systemtap/sssd_probes.d \
$(NULL)
+systemtap_tap_DATA = $(builddir)/src/systemtap/sssd.stp
+
stap_generated_probes.h: $(srcdir)/src/systemtap/sssd_probes.d
$(AM_V_GEN)$(DTRACE) -C -h -s $< -o $@
@@ -1103,7 +1106,6 @@ CLEANFILES += stap_generated_probes.h \
stap_generated_probes.o \
stap_generated_probes.lo \
$(NULL)
-
endif
####################