summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2016-03-02 14:33:38 -0500
committerJakub Hrozek <jhrozek@redhat.com>2016-03-09 18:34:39 +0100
commit5dbf360f2d6b0281c32f1bba6ebf5cc834c1716e (patch)
tree76b6fa8bcd9d2f6ffaa055a0367432e6a7daa6eb /Makefile.am
parent991c9f47fcb24704b880f60ab8ee77cfda056e2c (diff)
downloadsssd-5dbf360f2d6b0281c32f1bba6ebf5cc834c1716e.tar.gz
sssd-5dbf360f2d6b0281c32f1bba6ebf5cc834c1716e.tar.xz
sssd-5dbf360f2d6b0281c32f1bba6ebf5cc834c1716e.zip
Util: Move socket setup in a common utility file
Other components may need to connect sockets, the code here is generic enough that with minimal modifications can be used for non-ldap connections too. So create a sss_sockets.c/h utility file with all the non-ldap specific socket setup functions and make them available for other uses. Resolves: https://fedorahosted.org/sssd/ticket/2968 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e4f38a5e..d6eb0fc73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -541,6 +541,7 @@ dist_noinst_HEADERS = \
src/util/sss_python.h \
src/util/sss_krb5.h \
src/util/sss_selinux.h \
+ src/util/sss_sockets.h \
src/util/sss_utf8.h \
src/util/sss_ssh.h \
src/util/sss_ini.h \
@@ -1663,6 +1664,7 @@ ipa_ldap_opt_tests_SOURCES = \
src/providers/ad/ad_opts.c \
src/providers/ipa/ipa_opts.c \
src/providers/krb5/krb5_opts.c \
+ src/util/sss_sockets.c \
src/util/sss_ldap.c \
src/tests/ipa_ldap_opt-tests.c
ipa_ldap_opt_tests_CFLAGS = \
@@ -1877,6 +1879,7 @@ TEST_MOCK_RESP_OBJ = \
src/responder/common/responder_cache_req.c
TEST_MOCK_PROVIDER_OBJ = \
+ src/util/sss_sockets.c \
src/util/sss_ldap.c \
src/providers/data_provider_opts.c \
src/providers/ldap/ldap_opts.c \
@@ -2264,6 +2267,7 @@ sdap_tests_SOURCES = \
src/providers/ldap/sdap_range.c \
src/providers/ldap/ldap_opts.c \
src/providers/ipa/ipa_opts.c \
+ src/util/sss_sockets.c \
src/util/sss_ldap.c \
src/tests/cmocka/test_sdap.c \
$(NULL)
@@ -2879,6 +2883,7 @@ libsss_ldap_common_la_SOURCES = \
src/providers/ldap/sdap.c \
src/providers/ipa/ipa_dn.c \
src/util/user_info_msg.c \
+ src/util/sss_sockets.c \
src/util/sss_ldap.c \
$(NULL)
libsss_ldap_common_la_CFLAGS = \