summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <preichl@redhat.com>2016-04-22 14:26:53 +0200
committerJakub Hrozek <jhrozek@redhat.com>2016-06-20 14:48:47 +0200
commit49c467733ca65c9b77b9c33f38cdc223a99562e1 (patch)
treec2711558498b0288a3cc4c6e602de7fccbd6a185 /Makefile.am
parentb9d83e10cec267ae11fee64a30f42a12bbf7abe4 (diff)
downloadsssd-49c467733ca65c9b77b9c33f38cdc223a99562e1.tar.gz
sssd-49c467733ca65c9b77b9c33f38cdc223a99562e1.tar.xz
sssd-49c467733ca65c9b77b9c33f38cdc223a99562e1.zip
DP TESTS: Add unit tests for dp_request.c
Reviewed-by: Sumit Bose <sbose@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3298f0afd..ff0fd1a24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -253,6 +253,7 @@ if HAVE_CMOCKA
test_ldap_id_cleanup \
test_data_provider_be \
test_dp_request_table \
+ test_dp_request \
test_ipa_dn \
$(NULL)
@@ -2806,6 +2807,31 @@ test_dp_request_table_LDADD = \
libsss_test_common.la \
$(NULL)
+test_dp_request_SOURCES = \
+ src/providers/data_provider/dp_request.c \
+ src/providers/data_provider/dp_modules.c \
+ src/providers/data_provider/dp_targets.c \
+ src/providers/data_provider/dp_methods.c \
+ src/providers/data_provider/dp_builtin.c \
+ src/tests/cmocka/data_provider/mock_dp.c \
+ src/tests/cmocka/data_provider/test_dp_request.c \
+ src/tests/cmocka/common_mock_be.c \
+ $(NULL)
+test_dp_request_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING \
+ $(NULL)
+test_dp_request_LDFLAGS = \
+ -Wl,-wrap,be_is_offline \
+ $(NULL)
+test_dp_request_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(LIBADD_DL) \
+ libsss_test_common.la \
+ $(NULL)
+
test_ipa_dn_SOURCES = \
src/providers/ipa/ipa_dn.c \
src/tests/cmocka/test_ipa_dn.c \