summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-05-11 10:53:12 +0200
committerSumit Bose <sbose@redhat.com>2013-05-23 17:55:44 +0200
commitfb04b2de30a3d3556a15b5abb01856a749a0f7f3 (patch)
tree3bf2112146db83fe1afc3886f9a83b0ccd70fe6b /Makefile.am
parentd9435fded4db39421b43bb061c420ba66ff1835e (diff)
downloadsssd-fb04b2de30a3d3556a15b5abb01856a749a0f7f3.tar.gz
sssd-fb04b2de30a3d3556a15b5abb01856a749a0f7f3.tar.xz
sssd-fb04b2de30a3d3556a15b5abb01856a749a0f7f3.zip
Allow flat name in the FQname formatfq_review
https://fedorahosted.org/sssd/ticket/1648 Adds another expansion in the printf format that allows the user to use the domain flat name in the format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2bcb71457..0cc98734a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ if HAVE_CMOCKA
test-io \
sss_nss_idmap-tests \
test-io \
- dyndns-tests
+ dyndns-tests \
+ fqnames-tests
endif
check_PROGRAMS = \
@@ -1305,6 +1306,16 @@ dyndns_tests_LDADD = \
$(CARES_LIBS) \
$(CMOCKA_LIBS) \
libsss_util.la
+
+fqnames_tests_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_fqnames.c
+fqnames_tests_CFLAGS = \
+ $(AM_CFLAGS)
+fqnames_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ libsss_util.la
+
endif
noinst_PROGRAMS = pam_test_client