Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Combine fsp and tofd to tofsp in SMB_VFS_RECVFILE(). | Michael Adam | 2008-01-11 | 1 | -2/+0 |
| | | | | Michael | ||||
* | Remove redundant parameter fd from SMB_VFS_WRITE(). | Michael Adam | 2008-01-10 | 1 | -2/+2 |
| | | | | Michael | ||||
* | Remove redundant parameter fd from SMB_VFS_READ(). | Michael Adam | 2008-01-10 | 1 | -3/+3 |
| | | | | Michael | ||||
* | Make casts to (void *) explicit to remove compiler warnings. | Michael Adam | 2008-01-10 | 1 | -1/+2 |
| | | | | Michael | ||||
* | Correctly abstract the transfer_file mechanism with callbacks and void ptrs. | Michael Adam | 2008-01-10 | 1 | -11/+9 |
| | | | | | | This removes the in_fsp and out_fsp global variables hack from smbd/vfs.c. Michael | ||||
* | Make use of talloc_pool in the main codepaths. Remove the sub-contexts. | Jeremy Allison | 2008-01-09 | 1 | -9/+4 |
| | | | | Jeremy. | ||||
* | Remove redundant parameter fd from SMB_VFS_FTRUNCATE(). | Michael Adam | 2008-01-07 | 1 | -2/+2 |
| | | | | Michael | ||||
* | Remove redundant parameter fd from SMB_VFS_FSTAT(). | Michael Adam | 2008-01-07 | 1 | -2/+2 |
| | | | | Michael | ||||
* | Remove redundant parameter fd from SMB_VFS_PWRITE(). | Michael Adam | 2008-01-07 | 1 | -3/+3 |
| | | | | Michael | ||||
* | Remove unneeded parameter fd from SMB_VFS_PREAD(). | Michael Adam | 2008-01-07 | 1 | -1/+1 |
| | | | | Michael | ||||
* | Apply some const | Volker Lendecke | 2007-12-29 | 1 | -4/+4 |
| | |||||
* | Fix a C++ warning | Volker Lendecke | 2007-12-21 | 1 | -1/+1 |
| | |||||
* | Expose per-fsp extension talloc context. | James Peach | 2007-12-19 | 1 | -2/+14 |
| | | | | | This patch supplements the fsp extension API with an operation to retrieve the malloc zone pointer for that fsp. | ||||
* | Add a in-memory cache | Volker Lendecke | 2007-12-18 | 1 | -111/+57 |
| | | | | | | | | | | | This is a more general API that caches data with a LRU scheme. See include/cache.h. No comments yet, I'm still working on it. But Jeremy has given me a hint in one of his checkins that he would like to make use of this now. The idea is that we get rid of all our silly little caches and merge them all into one cache that we can then very easily trim, for example even with a smbcontrol message if someone decides memory is tight. The main user is the stat cache, this patch also converts the getwd cache. More caches to come. | ||||
* | Always define PATH_MAX. Makes code simpler (removes | Jeremy Allison | 2007-11-10 | 1 | -12/+0 |
| | | | | | a bunch of #defines). Remove pstring from msdfs.c. Jeremy. | ||||
* | Make explicit draining the socket on RECVFILE. Add | Jeremy Allison | 2007-10-31 | 1 | -10/+8 |
| | | | | | | | | capability for large UNIX write if not signing and recvfile set. Cope with large UNIX write length on incoming processing. Stevef - we can now test 1-16Mb writes from CIFFS. Jeremy. | ||||
* | Ensure we don't prematurely clean out the bytes read. | Jeremy Allison | 2007-10-30 | 1 | -4/+10 |
| | | | | Jeremy. | ||||
* | Add new parameter, "min receivefile size" (by default set | Jeremy Allison | 2007-10-30 | 1 | -3/+29 |
| | | | | | | | | | to zero). If non-zero, writeX calls greater than this value will be left in the socket buffer for later handling with recvfile (or userspace equivalent). Definition of recvfile for your system is left as an exercise for the reader (I'm working on getting splice working :-). Jeremy. | ||||
* | Enable vfs objects = /full/path/to/object.so | Volker Lendecke | 2007-10-28 | 1 | -10/+36 |
| | | | | | | | Right now I'm testing a vfs object. I can't right now in make test, because "vfs objects" assumes the .so files to be in $libdir/vfs. This patch parses the module name out of the object name in case it starts with "/". The module name is assumed to be the last path component's basename. | ||||
* | RIP BOOL. Convert BOOL -> bool. I found a few interesting | Jeremy Allison | 2007-10-18 | 1 | -11/+11 |
| | | | | | | | bugs in various places whilst doing this (places that assumed BOOL == int). I also need to fix the Samba4 pidl generation (next checkin). Jeremy. | ||||
* | r25117: The mega-patch Jerry was waiting for. Remove all pstrings from | Jeremy Allison | 2007-10-10 | 1 | -31/+79 |
| | | | | | | | | the main server code paths. We should now be able to cope with paths up to PATH_MAX length now. Final job will be to add the TALLOC_CTX * parameter to unix_convert to make it explicit (for Volker). Jeremy. | ||||
* | r23784: use the GPLv3 boilerplate as recommended by the FSF and the license text | Andrew Tridgell | 2007-10-10 | 1 | -2/+1 |
| | |||||
* | r23779: Change from v2 or later to v3 or later. | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | Jeremy. | ||||
* | r23761: Rename reduce_name to check_reduced_name | Volker Lendecke | 2007-10-10 | 1 | -1/+1 |
| | | | | | The function name reduce_name is misleading, making the user believe it changes an argument. | ||||
* | r22542: Move over to using the _strict varients of the talloc | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | | calls. No functional changes. Looks bigger than it is :-). Jeremy. | ||||
* | r22132: I hate inefficiency. Don't call conv_str_size() | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | | | | on every pread/sendfile call, initialize these variables in an allocated struct at connection time and just refer to them directly. Jeremy. | ||||
* | r21131: Some notify fixes | Volker Lendecke | 2007-10-10 | 1 | -1/+6 |
| | |||||
* | r21082: Make canonicalize_path static to service.c -- we do have ↵ | Volker Lendecke | 2007-10-10 | 1 | -25/+0 |
| | | | | conn->connectpath | ||||
* | r21063: All case statements are now NTSTATUS returning | Jeremy Allison | 2007-10-10 | 1 | -0/+1 |
| | | | | | | | functions. Now to factor out the post processing and make all cases behave the same (no mixture of "early returns" and "break"s. Jeremy | ||||
* | r20844: Somewhat radical change - this may break the build (I will | Jeremy Allison | 2007-10-10 | 1 | -23/+17 |
| | | | | | | | | | | | | watch carefully - so I'm doing it in one transaction so I can roll back). Change check_name(), reduce_name() and dptr_create() to return NTSTATUS. This helps a lot in error path processing and especially in reduce_name() allows us to ditch the flaky and error-prone saving of errno and return errors directly. Jeremy. | ||||
* | r20340: Join vfs_MkDir to its only caller | Volker Lendecke | 2007-10-10 | 1 | -31/+0 |
| | |||||
* | r20228: Bring the calling conventions of inherit_access_acl and ↵ | Volker Lendecke | 2007-10-10 | 1 | -1/+3 |
| | | | | | | | | change_owner_to_parent a bit closer together: Move the lp_inherit_perms() check into the callers. Volker | ||||
* | r20227: Simplify logic in vfs_MkDir() a bit | Volker Lendecke | 2007-10-10 | 1 | -11/+15 |
| | |||||
* | r19147: This is WRONG, but the way the VFS works this is the only fix to get ↵ | Volker Lendecke | 2007-10-10 | 1 | -1/+1 |
| | | | | | | | | rid of this type-punned warning. Volker | ||||
* | r17348: Some C++ warnings | Volker Lendecke | 2007-10-10 | 1 | -3/+3 |
| | |||||
* | r16945: Sync trunk -> 3.0 for 3.0.24 code. Still need | Jeremy Allison | 2007-10-10 | 1 | -137/+80 |
| | | | | | | | to do the upper layer directories but this is what everyone is waiting for.... Jeremy. | ||||
* | r15283: Oh yeah. The build farm doesn't do much with head. OK, here is the ↵ | Paul Green | 2007-10-10 | 1 | -0/+2 |
| | | | | patch to SAMBA_3_0 to declare prototypes for the initialization functions. These are the same changes I just made to head. --paulg | ||||
* | r15018: Merge Volker's ipc/trans2/nttrans changes over | Jeremy Allison | 2007-10-10 | 1 | -0/+1 |
| | | | | | | | | into 3.0. Also merge the new POSIX lock code - this is not enabled unless -DDEVELOPER is defined. This doesn't yet map onto underlying system POSIX locks. Updates vfs to allow lock queries. Jeremy. | ||||
* | r14746: Add the Samba4 replacements for opendir/readdir etc. to | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | | | | Samba3 - with some 64-bit macro madness. Attempt to fix the broken directory handling in the *BSD-of-the-month club. Jeremy. | ||||
* | r11428: Fix bug #3192 by actually hooking up the dfree caching | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | | function. Oops. Jeremy. | ||||
* | r11232: Added ab's POSIX statvfs vfs call. Sorry for the delay ab. | Jeremy Allison | 2007-10-10 | 1 | -0/+1 |
| | | | | Jeremy. | ||||
* | r8219: Merge the new open code from HEAD to 3.0. Haven't yet run the torture | Jeremy Allison | 2007-10-10 | 1 | -10/+10 |
| | | | | | | | | | tests on this as it's very late NY time (just wanted to get this work into the tree). I'll test this over the weekend.... Jerry - in looking at the difference between the two trees there seem to be some printing/ntprinting.c and registry changes we might want to examine to try keep in sync. Jeremy. | ||||
* | r7963: Add aio support to 3.0. | Jeremy Allison | 2007-10-10 | 1 | -15/+24 |
| | | | | Jeremy. | ||||
* | r6841: Attempt to fix buf #2681. With "strict allocate = yes" we now zero | Jeremy Allison | 2007-10-10 | 1 | -0/+66 |
| | | | | | | fill when a file is extended. Should catch disk full errors on write from MS-Office. Jeremy. | ||||
* | r6633: Added "check_path_syntax_posix()" in preparation for handling | Jeremy Allison | 2007-10-10 | 1 | -2/+4 |
| | | | | | POSIX pathnames. Not yet used. Jeremy. | ||||
* | r6408: Fix compile error lurking where PATH_MAX is not defined. Bugzilla #2560. | Tim Potter | 2007-10-10 | 1 | -1/+1 |
| | |||||
* | r6234: Fix for possible root squash nfs bugs from psz@maths.usyd.edu.au | Jeremy Allison | 2007-10-10 | 1 | -1/+3 |
| | | | | Jeremy. | ||||
* | r5825: Fix one more DISK_FREE call - spotted by Ying Li <ying.li2@hp.com>. | Jeremy Allison | 2007-10-10 | 1 | -0/+3 |
| | | | | Jeremy. | ||||
* | r5757: Fix erroneous debug message - noticed by William Jojo <jojowil@hvcc.edu>. | Jeremy Allison | 2007-10-10 | 1 | -1/+1 |
| | | | | Jeremy. | ||||
* | r4088: Get medieval on our ass about malloc.... :-). Take control of all our ↵ | Jeremy Allison | 2007-10-10 | 1 | -4/+4 |
| | | | | | | | | | allocation functions so we can funnel through some well known functions. Should help greatly with malloc checking. HEAD patch to follow. Jeremy. |