summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 1092d00b17d..6594e7cca46 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3550,6 +3550,25 @@ if test x"$with_ads_support" != x"no"; then
WINBIND_KRB5_LOCATOR="bin/winbind_krb5_locator.$SHLIBEXT"
EXTRA_ALL_TARGETS="$EXTRA_ALL_TARGETS $WINBIND_KRB5_LOCATOR"
fi
+
+ # check for new heimdal KRB5_DEPRECATED handling
+
+ AC_CACHE_CHECK([for KRB5_DEPRECATED define taking an identifier],
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER,[
+ AC_TRY_COMPILE(
+ [#define KRB5_DEPRECATED 1
+ #include <krb5.h>],
+ [void main(void) {}],
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER=yes,
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER" = x"yes"; then
+ AC_DEFINE(KRB5_DEPRECATED, 1,
+ [Whether to use deprecated krb5 interfaces])
+ else
+ AC_DEFINE(KRB5_DEPRECATED,,
+ [Whether to use deprecated krb5 interfaces])
+ fi
fi
# Now we have determined whether we really want ADS support