summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/source/configure.in b/source/configure.in
index f19a8ed18c7..e9ad6af93e4 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2733,12 +2733,14 @@ samba_cv_HAVE_ACL_GET_PERM_NP=yes,samba_cv_HAVE_ACL_GET_PERM_NP=no)])
#################################################
# check for sendfile support
-AC_MSG_CHECKING(whether to support sendfile)
+AC_MSG_CHECKING(whether to check for support sendfile)
AC_ARG_WITH(sendfile-support,
-[ --with-sendfile-support Include sendfile support (default=no)],
+[ --with-sendfile-support Check for sendfile support (default=no)],
[ case "$withval" in
yes)
+ AC_MSG_RESULT(yes);
+
case "$host_os" in
*linux*)
AC_CACHE_CHECK([for linux sendfile64 support],samba_cv_HAVE_SENDFILE64,[
@@ -2884,6 +2886,7 @@ samba_cv_HAVE_SENDFILE=yes,samba_cv_HAVE_SENDFILE=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;
@@ -2916,6 +2919,7 @@ samba_cv_HAVE_SENDFILEV64=yes,samba_cv_HAVE_SENDFILEV64=no)])
size_t xferred;
struct sendfilevec vec[2];
ssize_t nwritten;
+ int tofd;
sfvcnt = 2;