summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 82e512bf518..7edf9c35b5d 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1233,6 +1233,27 @@ AC_ARG_WITH(privatedir,
)
#################################################
+# set lock directory location
+AC_ARG_WITH(lockdir,
+[ --with-lockdir=DIR Where to put lock files ($ac_default_prefix/var/locks)],
+[ case "$withval" in
+ yes|no)
+ #
+ # Just in case anybody calls it without argument
+ #
+ AC_MSG_WARN([--with-lockdir called without argument - will use default])
+ lockdir='$(VARDIR)/locks'
+ ;;
+ * )
+ lockdir="$withval"
+ ;;
+ esac
+ AC_SUBST(lockdir)],
+ [lockdir='$(VARDIR)/locks'
+ AC_SUBST(lockdir)]
+)
+
+#################################################
# set SWAT directory location
AC_ARG_WITH(swatdir,
[ --with-swatdir=DIR Where to put SWAT files ($ac_default_prefix/swat)],