summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 4ad5a054025..98a5ad14983 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -256,6 +256,12 @@ AC_TRY_COMPILE([#include <sys/types.h>
echo yes;AC_DEFINE(HAVE_UTIMBUF),
echo no)
+
+echo $ac_n "checking for test routines ... $ac_c"
+AC_TRY_RUN([#include "tests/trivial.c"],
+ echo yes;,
+ echo ERROR - cant find test code. Aborting config; exit 1)
+
echo $ac_n "checking for ftruncate extend ... $ac_c"
AC_TRY_RUN([#include "tests/ftruncate.c"],
echo yes;AC_DEFINE(HAVE_FTRUNCATE_EXTEND),