summaryrefslogtreecommitdiffstats
path: root/packaging/Debian/debian/scripts/unpatch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/scripts/unpatch-source')
-rwxr-xr-xpackaging/Debian/debian/scripts/unpatch-source11
1 files changed, 10 insertions, 1 deletions
diff --git a/packaging/Debian/debian/scripts/unpatch-source b/packaging/Debian/debian/scripts/unpatch-source
index 81d51f7dd4e..057ae43c3b4 100755
--- a/packaging/Debian/debian/scripts/unpatch-source
+++ b/packaging/Debian/debian/scripts/unpatch-source
@@ -1,7 +1,16 @@
#!/bin/sh -e
+#
+#
-for patch in debian/patches/*.patch; do
+# We want to reverse the patches in the opposite order we applied
+# them, hence the 'ls|sort -r'.
+for patch in `ls debian/patches/*.patch | sort -r`; do
patch -p1 -R < $patch
done
+perl -pi -e's/-.* for Debian//' source/include/version.h
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && autoconf)
+
exit 0