summaryrefslogtreecommitdiffstats
path: root/packaging/Debian/debian-unstable/scripts/patch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian-unstable/scripts/patch-source')
-rwxr-xr-xpackaging/Debian/debian-unstable/scripts/patch-source28
1 files changed, 28 insertions, 0 deletions
diff --git a/packaging/Debian/debian-unstable/scripts/patch-source b/packaging/Debian/debian-unstable/scripts/patch-source
new file mode 100755
index 00000000000..a8559b41676
--- /dev/null
+++ b/packaging/Debian/debian-unstable/scripts/patch-source
@@ -0,0 +1,28 @@
+#!/bin/sh -e
+#
+#
+
+for patch in debian/patches/*.patch; do
+ echo '->'`basename $patch`:
+ patch -p1 --ignore-whitespace < $patch
+done
+
+# This code is currently not used because it creates a long version
+# number string. For now we're sticking to <upstream version>-Debian,
+# as in 3.0.0rc2-Debian. peloy@debian.org.-
+
+# ---- Begin unused code ----
+# Get Debian version number from 1st line of the Debian changelog
+#DEBIAN_VERSION=`sed -n -e '1s/^.*(\(.*\)).*$/\1/p' debian/changelog`
+
+# Insert Debian version number in source/VERSION, which will then be
+# used to create source/include/version.h.
+#TMPFILE=source/VERSION.debian
+#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1\"Debian-${DEBIAN_VERSION}\"/" source/VERSION > ${TMPFILE}
+#mv -f ${TMPFILE} source/VERSION
+# ---- End unused code ----
+
+# Regenerate configure only if it is older than configure.in
+[ source/configure -ot source/configure.in ] && (cd source && sh ./autogen.sh)
+
+exit 0