summaryrefslogtreecommitdiffstats
path: root/source/python/setup.py
diff options
context:
space:
mode:
authorLars Müller <lmuelle@samba.org>2006-01-31 10:39:45 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:06:20 -0500
commit4602cb5f53f05404f10c69b01dd8fd5ac492c5c5 (patch)
tree8d827db47a12468eb22901bef6d9457118195687 /source/python/setup.py
parent6f5af1dd413d07430ead9382422dda14acf3464d (diff)
downloadsamba-4602cb5f53f05404f10c69b01dd8fd5ac492c5c5.tar.gz
samba-4602cb5f53f05404f10c69b01dd8fd5ac492c5c5.tar.xz
samba-4602cb5f53f05404f10c69b01dd8fd5ac492c5c5.zip
r13257: Fix python build with older python versions (e.g. 2.2.1) like in United Linux 1 (UL) aka SuSE Linux Enterprise Server (SLES) 8.
Diffstat (limited to 'source/python/setup.py')
-rwxr-xr-xsource/python/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/source/python/setup.py b/source/python/setup.py
index ffdafd70877..ce417710b30 100755
--- a/source/python/setup.py
+++ b/source/python/setup.py
@@ -63,9 +63,9 @@ for lib in string.split(samba_libs):
next_is_flag = 0;
elif lib == "-Wl,-rpath":
next_is_path = 1;
- elif lib[0:2] in ("-l"):
+ elif lib[0:2] == ("-l"):
libraries.append(lib[2:])
- elif lib[0:8] in ("-pthread"):
+ elif lib[0:8] == ("-pthread"):
pass # Skip linker flags
elif lib[0:2] == "-L":
library_dirs.append(lib[2:])