summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2008-04-28 11:44:26 +0200
committerMichael Adam <obnox@samba.org>2008-08-13 11:54:05 +0200
commitfc9b30bed2d774dca6660b497cb50f982b23b885 (patch)
tree7e7911223ed74da46db76701bd437b659b56bb83 /source/configure.in
parent7f3787a79a9949e7e80c9c5e16ec504ad1c4bdb7 (diff)
downloadsamba-fc9b30bed2d774dca6660b497cb50f982b23b885.tar.gz
samba-fc9b30bed2d774dca6660b497cb50f982b23b885.tar.xz
samba-fc9b30bed2d774dca6660b497cb50f982b23b885.zip
Add a gpfs_prefetch module
This can not go upstream yet because it uses the non-GPL libgpfs. So it will not be compiled by default and will not be included in the SOFS RPMs. But upon Sven's request, we include it in the git tree and the source RPMs, so that it can be built for in-house tests.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index c7698590a92..a53db4e3efa 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1056,7 +1056,7 @@ AC_TRY_LINK([#include <gpfs_gpl.h>],
echo $samba_cv_HAVE_GPFS
if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL libs are available])
- default_shared_modules="$default_shared_modules vfs_gpfs"
+ default_shared_modules="$default_shared_modules vfs_gpfs vfs_gpfs_prefetch"
fi
LIBS="$save_LIBS"
@@ -5986,6 +5986,7 @@ SMB_MODULE(vfs_cacheprime, \$(VFS_CACHEPRIME_OBJ), "bin/cacheprime.$SHLIBEXT", V
SMB_MODULE(vfs_prealloc, \$(VFS_PREALLOC_OBJ), "bin/prealloc.$SHLIBEXT", VFS)
SMB_MODULE(vfs_commit, \$(VFS_COMMIT_OBJ), "bin/commit.$SHLIBEXT", VFS)
SMB_MODULE(vfs_gpfs, \$(VFS_GPFS_OBJ), "bin/gpfs.$SHLIBEXT", VFS)
+SMB_MODULE(vfs_gpfs_prefetch, \$(VFS_GPFS_PREFETCH_OBJ), "bin/gpfs_prefetch.$SHLIBEXT", VFS)
SMB_MODULE(vfs_readahead, \$(VFS_READAHEAD_OBJ), "bin/readahead.$SHLIBEXT", VFS)
SMB_MODULE(vfs_tsmsm, \$(VFS_TSMSM_OBJ), "bin/tsmsm.$SHLIBEXT", VFS)
SMB_MODULE(vfs_fileid, \$(VFS_FILEID_OBJ), "bin/fileid.$SHLIBEXT", VFS)