summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2008-06-17 22:45:29 +1000
committerVolker Lendecke <vl@samba.org>2008-08-05 16:19:54 +0200
commit91c17ecfd7b07ff948874c3eb7013eb79c5b66ab (patch)
tree6c9bd81950956017b326210ac62374c76d3f02c7 /source/configure.in
parentc06ee7cd99c44f10fd7cf9926fe1511664f53ac3 (diff)
downloadsamba-91c17ecfd7b07ff948874c3eb7013eb79c5b66ab.tar.gz
samba-91c17ecfd7b07ff948874c3eb7013eb79c5b66ab.tar.xz
samba-91c17ecfd7b07ff948874c3eb7013eb79c5b66ab.zip
Without stdlib.h we don't get a prototype for free().
This test fails if GCC emits any warnings (presumably to detect the function propertly), but unless we include this message then free() fail. Why we need to call free in a configure test is probably something to blame on valgrind... Andrew Bartlett (cherry picked from commit d013f6fadc3e80fabb4a1784207dabc84f9b7dc2)
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 9a230dece6e..c2b02489002 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3747,6 +3747,7 @@ if test x"$with_ads_support" != x"no"; then
AC_CACHE_CHECK([for krb5_error_code krb5_enctype_to_string(krb5_context context, krb5_enctype enctype, char **str)],
smb_krb5_cv_enctype_to_string_takes_krb5_context_arg,[
AC_TRY_RUN_STRICT([
+ #include <stdlib.h>
#include <krb5.h>
int main(void) {
krb5_context context = NULL;