summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2001-06-01 11:53:48 +0000
committerTim Potter <tpot@samba.org>2001-06-01 11:53:48 +0000
commitde46428d054285f568727589537cd8520ee0f687 (patch)
tree8a16cbb83b7d712b48eb21c2683fbe5b597d69c5 /source/configure.in
parent1bc58c21b15fcdb0a504d051f60e20c4e24441e6 (diff)
downloadsamba-de46428d054285f568727589537cd8520ee0f687.tar.gz
samba-de46428d054285f568727589537cd8520ee0f687.tar.xz
samba-de46428d054285f568727589537cd8520ee0f687.zip
Added a --with/without winbind option to configure. The default is to
compile winbind on supported systems but this may be disabled using --without-winbind. Using --with-winbind on unsupported systems has no effect.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in34
1 files changed, 26 insertions, 8 deletions
diff --git a/source/configure.in b/source/configure.in
index f7751dc0f51..45533f72ec8 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2196,16 +2196,34 @@ samba_cv_HAVE_XFS_ACLS=yes,samba_cv_XFS_POSIX_ACLS=no)])
# check whether winbind is supported on this platform
AC_MSG_CHECKING(whether to compile winbind)
-case "$host_os" in
- *linux*|*solaris*)
- AC_MSG_RESULT(yes)
- WINBIND_TARGETS="$WINBIND_TARGETS \$(WINBIND_PROGS)"
- ;;
- *)
- AC_MSG_RESULT(unsupported for $host_os)
- ;;
+
+case "$host_os" in
+ *linux*|*solaris*)
+ WINBIND_TARGETS="$WINBIND_TARGETS \$(WINBIND_PROGS)"
+ ;;
+ *)
+ winbind_no_reason=", unsupported on $host_os"
+ ;;
esac
+AC_ARG_WITH(winbind,
+[ --with-winbind Build winbind library (default, if supported by OS)
+ --without-winbind Don't build winbind library],
+[
+ case "$withval" in
+ no)
+ WINBIND_TARGETS=""
+ winbind_reason=""
+ ;;
+ esac ],
+)
+
+if test x"$WINBIND_TARGETS" = x; then
+ AC_MSG_RESULT(no$winbind_no_reason)
+else
+ AC_MSG_RESULT(yes)
+fi
+
AC_SUBST(WINBIND_TARGETS)
#################################################