summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2007-12-15 23:22:25 -0800
committerJeremy Allison <jra@samba.org>2007-12-15 23:22:25 -0800
commitd0e33840fb4cfc85990d3ee327428b0854a22722 (patch)
tree04f20f887ba4e64d9aa299338498f1f2e87bcfeb /source/configure.in
parente799eb8da6f5e7a2173ba6b8fb040430fd1c6f34 (diff)
downloadsamba-d0e33840fb4cfc85990d3ee327428b0854a22722.tar.gz
samba-d0e33840fb4cfc85990d3ee327428b0854a22722.tar.xz
samba-d0e33840fb4cfc85990d3ee327428b0854a22722.zip
Added patch originally by Andreas Schneider <anschneider@suse.de>
to cause us to behave like Vista when looking for remote machine principal. Modified by me. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 7272ae4d9ac..ac60b6f645f 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -4221,6 +4221,30 @@ if test x"$with_ads_support" != x"no"; then
fi
fi
+ AC_CACHE_CHECK([for krb5_principal_get_realm],
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM,[
+ AC_TRY_LINK([#include <krb5.h>],
+ [krb5_context ctx = NULL; krb5_principal princ = NULL; const char *str = krb5_principal_get_realm(ctx, princ);],
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM=yes,
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM" = x"yes"; then
+ AC_DEFINE(HAVE_KRB5_PRINCIPAL_GET_REALM,1,
+ [Whether the function krb5_principal_get_realm is defined])
+ fi
+
+ AC_CACHE_CHECK([for krb5_princ_realm],
+ samba_cv_HAVE_KRB5_PRINC_REALM,[
+ AC_TRY_LINK([#include <krb5.h>],
+ [krb5_context ctx = NULL; krb5_principal princ = NULL; const char *str = krb5_princ_realm(ctx, princ)->data;],
+ samba_cv_HAVE_KRB5_PRINC_REALM=yes,
+ samba_cv_HAVE_KRB5_PRINC_REALM=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_PRINC_REALM" = x"yes"; then
+ AC_DEFINE(HAVE_KRB5_PRINC_REALM,1,
+ [Whether the macro krb5_princ_realm is defined])
+ fi
+
#
#
# Now the decisions whether we can support krb5