summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2000-03-29 23:03:48 +0000
committerJeremy Allison <jra@samba.org>2000-03-29 23:03:48 +0000
commit567713a07c089ab3ebb4c9b96087777de154b601 (patch)
treef0d6ad8c5aff8b0e6a3398d0e709bb10ac26099d /source/configure.in
parent1c9d2c016a78b0ed11dc68adeabb709903444837 (diff)
downloadsamba-567713a07c089ab3ebb4c9b96087777de154b601.tar.gz
samba-567713a07c089ab3ebb4c9b96087777de154b601.tar.xz
samba-567713a07c089ab3ebb4c9b96087777de154b601.zip
Added check for LL suffix to long long ints needed by AIX 4.3.x compiler
to allow successful build. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 61af9f76ec1..731b3b12334 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -548,6 +548,18 @@ if test x"$samba_cv_have_longlong" = x"yes"; then
AC_DEFINE(HAVE_LONGLONG)
fi
+#
+# Check if the compiler supports the LL prefix on long long integers.
+# AIX needs this.
+
+AC_CACHE_CHECK([for LL suffix on long long integers],samba_cv_compiler_supports_ll, [
+ AC_TRY_COMPILE([#include <stdio.h>],[long long i = 0x8000000000LL],
+ samba_cv_compiler_supports_ll=yes,samba_cv_compiler_supports_ll=no)])
+if test x"$samba_cv_compiler_supports_ll" = x"yes"; then
+ AC_DEFINE(COMPILER_SUPPORTS_LL)
+fi
+
+
AC_CACHE_CHECK([for 64 bit off_t],samba_cv_SIZEOF_OFF_T,[
AC_TRY_RUN([#include <stdio.h>
#include <sys/stat.h>