summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorShirish Kalele <kalele@samba.org>2000-03-08 22:14:30 +0000
committerShirish Kalele <kalele@samba.org>2000-03-08 22:14:30 +0000
commit4684b4a188b54493dbe7f0de2909a8d3c5c3ebf9 (patch)
treea7f513ad4987db5c3e503b94402d35c2a5a80ec6 /source/configure.in
parentf8d3ce0419aee44e4d5efe1257ce4b27f7511ceb (diff)
downloadsamba-4684b4a188b54493dbe7f0de2909a8d3c5c3ebf9.tar.gz
samba-4684b4a188b54493dbe7f0de2909a8d3c5c3ebf9.tar.xz
samba-4684b4a188b54493dbe7f0de2909a8d3c5c3ebf9.zip
dded Microsoft Dfs services.
* added a new msdfs/ directory under source/ * added msdfs sources under this directory. * modified configure setup to add a --with-msdfs configure time option Modified Files: Makefile.in acconfig.h configure configure.in include/config.h.in include/includes.h include/proto.h include/smb.h include/smb_macros.h param/loadparm.c smbd/negprot.c smbd/nttrans.c smbd/process.c smbd/reply.c smbd/server.c smbd/trans2.c Added Files: include/msdfs.h msdfs/README msdfs/msdfs.c msdfs/msdfs_tdb.c msdfs/parse_dfs_map.c ----------------------------------------------------------------------
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 4d8ef647c80..47ad2f97eaf 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1424,6 +1424,25 @@ AC_ARG_WITH(utmp,
)
#################################################
+# check for MS Dfs support
+
+AC_MSG_CHECKING(whether to support MS Dfs)
+AC_ARG_WITH(msdfs,
+[ --with-msdfs Include MS Dfs support
+ --without-msdfs Don't include MS Dfs support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(MS_DFS)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+#################################################
# set private directory location
AC_ARG_WITH(privatedir,
[ --with-privatedir=DIR Where to put smbpasswd ($ac_default_prefix/private)],