summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-11-14 23:52:49 +0000
committerAndrew Tridgell <tridge@samba.org>1998-11-14 23:52:49 +0000
commit263b13222c14db7ddec1430132c6362be4442147 (patch)
tree28809e50cb54dff802fa981711feddd461f3e7f0 /source/configure.in
parent0f98a2fd58aee1dac4d0f4098a2e690dfaf5ba27 (diff)
downloadsamba-263b13222c14db7ddec1430132c6362be4442147.tar.gz
samba-263b13222c14db7ddec1430132c6362be4442147.tar.xz
samba-263b13222c14db7ddec1430132c6362be4442147.zip
compile with optimisation by default on all compilers
this has 2 effects: 1) non gcc platforms get some optimisation 2) it disables -g by default which means the samba binaries won't be so huge (they were over 60MB on some systems)
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 65c31d434fc..178d566c805 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -10,6 +10,10 @@ AC_SUBST(HOST_OS)
AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
+
+# compile with optimisation and without debugging by default
+CFLAGS=${CFLAGS-"-O"}
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL