summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2001-07-23 11:22:29 +0000
committerRichard Sharpe <sharpe@samba.org>2001-07-23 11:22:29 +0000
commitd63b03f7536abb0745ad2a084c44108a3c19a8b6 (patch)
tree8f457cfbf4ae83f945d7784ed06863a17c842714 /source/configure.in
parentbc0317678299028cd9f9de8c0daf9f06318cce13 (diff)
downloadsamba-d63b03f7536abb0745ad2a084c44108a3c19a8b6.tar.gz
samba-d63b03f7536abb0745ad2a084c44108a3c19a8b6.tar.xz
samba-d63b03f7536abb0745ad2a084c44108a3c19a8b6.zip
Fix the POOBAD_CC on Slowaris so we can handle things correctly ...
Lets see how this goes.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 138be6c27cf..8385be9d452 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -15,6 +15,8 @@ AC_SUBST(PAM_MOD)
AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
+AC_SUBST(PICSUFFIX)
+AC_SUBST(POBAD_CC)
AC_SUBST(SHLIBEXT)
AC_SUBST(BLDSHARED)
@@ -609,6 +611,8 @@ HOST_OS="$host_os"
LDSHFLAGS="-shared"
SHLD="\${CC}"
PICFLAG=""
+PICSUFFIX="po"
+POBAD_CC="#"
SHLIBEXT="so"
BLDSHARED="false"
@@ -622,7 +626,13 @@ case "$host_os" in
*solaris*) AC_DEFINE(SUNOS5)
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
- PICFLAG="-KPIC -xO4"
+ if test "${ac_cv_prog_CC}" = "gcc"; then
+ PICFLAG="-fPIC"
+ else
+ PICFLAG="-KPIC -xO4"
+ POBAD_CC=""
+ PICSUFFIX="po.o"
+ fi
;;
*sunos*) AC_DEFINE(SUNOS4)
BLDSHARED="true"