summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2007-03-15 19:18:18 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:18:37 -0500
commitc426340fc79a6b446033433b8de599130adffe28 (patch)
tree39c096e5c2cca424bf0a093a9db05ac0619739d7 /source/configure.in
parentbd9439cc7d80e172feab72229b553028e134de05 (diff)
downloadsamba-c426340fc79a6b446033433b8de599130adffe28.tar.gz
samba-c426340fc79a6b446033433b8de599130adffe28.tar.xz
samba-c426340fc79a6b446033433b8de599130adffe28.zip
r21845: Refactor the sessionsetupX code a little to allow us
to return a NT_STATUS_TIME_DIFFERENCE_AT_DC error to a client when there's clock skew. Will help people debug this. Prepare us for being able to return the correct sessionsetupX "NT_STATUS_MORE_PROCESSING_REQUIRED" error with associated krb5 clock skew error to allow clients to re-sync time with us when we're eventually able to be a KDC. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 5cd07924f65..0b2f8bd9053 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3886,6 +3886,20 @@ if test x"$with_ads_support" != x"no"; then
[Whether the type krb5_addresses type exists])
fi
+ AC_CACHE_CHECK([whether krb5_mk_error takes 3 arguments MIT or 9 Heimdal],
+ samba_cv_HAVE_SHORT_KRB5_MK_ERROR_INTERFACE, [
+ AC_TRY_COMPILE([#include <krb5.h>],
+ [
+ krb5_mk_error(0,0,0);],
+ samba_cv_HAVE_SHORT_KRB5_MK_ERROR_INTERFACE=yes,
+ samba_cv_HAVE_SHORT_KRB5_MK_ERROR_INTERFACE=no)])
+
+ if test x"$samba_cv_HAVE_SHORT_KRB5_MK_ERROR_INTERFACE" = x"yes"; then
+ AC_DEFINE(HAVE_SHORT_KRB5_MK_ERROR_INTERFACE,1,
+ [whether krb5_mk_error takes 3 arguments MIT or 9 Heimdal])
+ fi
+
+
#
#
# Now the decisions whether we can support krb5