summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2008-05-16 12:50:16 +0200
committerKarolin Seeger <kseeger@samba.org>2008-05-22 16:47:44 +0200
commit77faf99b3834ae443ceed487a4012a3676d6453f (patch)
tree1db2ed557d10ba766b2114021c9f2e0482a161d4 /source/configure.in
parent4f2cb7b8b63d30c354fbd6086a9b818cbb45968e (diff)
downloadsamba-77faf99b3834ae443ceed487a4012a3676d6453f.tar.gz
samba-77faf99b3834ae443ceed487a4012a3676d6453f.tar.xz
samba-77faf99b3834ae443ceed487a4012a3676d6453f.zip
configure: make use of LIBREPLACE_NETWORK_LIBS instead of redoing the tests
metze (cherry picked from commit 4b484426f52d5ed37af117f5ade63816f1c9b0ea)
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in40
1 files changed, 3 insertions, 37 deletions
diff --git a/source/configure.in b/source/configure.in
index 59d555e4123..1da612a631c 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -663,7 +663,7 @@ done
AC_SUBST(LIBREPLACE_OBJS)
# add -ldl to the global LIBS
-LIBS="${LIBS} ${LIBDL}"
+LIBS="${LIBS} ${LIBDL} ${LIBREPLACE_NETWORK_LIBS}"
AC_CHECK_HEADERS(aio.h sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h rpc/nettype.h)
AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h memory.h alloca.h)
@@ -997,40 +997,6 @@ AC_CHECK_LIB(readline, history_list,
[],
[$TERMLIBS])
-# The following test taken from the cvs sources
-# If we can't find connect, try looking in -lsocket, -lnsl, and -linet.
-# The Irix 5 libc.so has connect and gethostbyname, but Irix 5 also has
-# libsocket.so which has a bad implementation of gethostbyname (it
-# only looks in /etc/hosts), so we only look for -lsocket if we need
-# it.
-AC_CHECK_FUNCS(connect)
-if test x"$ac_cv_func_connect" = x"no"; then
- case "$LIBS" in
- *-lnsl*) ;;
- *) AC_CHECK_LIB(nsl_s, connect) ;;
- esac
- case "$LIBS" in
- *-lnsl*) ;;
- *) AC_CHECK_LIB(nsl, connect) ;;
- esac
- case "$LIBS" in
- *-lsocket*) ;;
- *) AC_CHECK_LIB(socket, connect) ;;
- esac
- case "$LIBS" in
- *-linet*) ;;
- *) AC_CHECK_LIB(inet, connect) ;;
- esac
- dnl We can't just call AC_CHECK_FUNCS(connect) here, because the value
- dnl has been cached.
- if test x"$ac_cv_lib_socket_connect" = x"yes" ||
- test x"$ac_cv_lib_inet_connect" = x"yes"; then
- # ac_cv_func_connect=yes
- # don't! it would cause AC_CHECK_FUNC to succeed next time configure is run
- AC_DEFINE(HAVE_CONNECT,1,[Whether the system has connect()])
- fi
-fi
-
###############################################
# test for where we get yp_get_default_domain() from
AC_SEARCH_LIBS(yp_get_default_domain, [nsl])
@@ -5689,8 +5655,8 @@ case "$host_os" in
NSSSONAMEVERSIONSUFFIX=".1"
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris.o \
nsswitch/winbind_nss_linux.o"
- WINBIND_NSS_EXTRA_LIBS="-lsocket"
- PAM_WINBIND_EXTRA_LIBS="-lsocket"
+ WINBIND_NSS_EXTRA_LIBS="${LIBREPLACE_NETWORK_LIBS}"
+ PAM_WINBIND_EXTRA_LIBS="${LIBREPLACE_NETWORK_LIBS}"
;;
*hpux11*)
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris.o"