summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2005-03-25 14:37:10 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:56:19 -0500
commit605dd5b97c09fd3e6bc09eefa78ef333201c0b7c (patch)
tree5416f44671a1ed0ae923f2053c39dfaaab2fd902 /source/configure.in
parente3c7d08bb68f51bc05768467feb0af896a059e91 (diff)
downloadsamba-605dd5b97c09fd3e6bc09eefa78ef333201c0b7c.tar.gz
samba-605dd5b97c09fd3e6bc09eefa78ef333201c0b7c.tar.xz
samba-605dd5b97c09fd3e6bc09eefa78ef333201c0b7c.zip
r6062: work around autoconf setting the CFLAGS="-g -O2" by default in AC_CACHE_CHECK
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in17
1 files changed, 10 insertions, 7 deletions
diff --git a/source/configure.in b/source/configure.in
index 72a04375a2d..9b2f4b80ce5 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -235,6 +235,16 @@ AC_ARG_ENABLE(debug,
CFLAGS="${CFLAGS} -g"
fi])
+# compile with optimization and without debugging by default, but
+# allow people to set their own preference.
+# do this here since AC_CACHE_CHECK apparently sets the CFLAGS to "-g -O2"
+# if it has no value. This prevent *very* large debug binaries from occurring
+# by default.
+if test "x$CFLAGS" = x; then
+ CFLAGS="-O"
+fi
+
+
AC_ARG_ENABLE(developer, [ --enable-developer Turn on developer warnings and debugging (default=no)],
[if eval "test x$enable_developer = xyes"; then
developer=yes
@@ -293,13 +303,6 @@ AC_PATH_PROG(PERL, perl)
AC_CHECK_TOOL(AR, ar)
-# compile with optimization and without debugging by default, but
-# allow people to set their own preference.
-if test "x$CFLAGS" = x
-then
- CFLAGS="-O ${CFLAGS}"
-fi
-
dnl Check if we use GNU ld
LD=ld
AC_PROG_LD_GNU