summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-09-27 01:02:37 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-09-27 01:02:37 +0000
commit36c2a3820faa1d90cd331881720be0e61ab93460 (patch)
treef0cc2cbd3ebef94d94e989633e9f59367defc31f /source/configure.in
parentece9507ec3d363fccf56b000ad9758780a9b3fb4 (diff)
downloadsamba-36c2a3820faa1d90cd331881720be0e61ab93460.tar.gz
samba-36c2a3820faa1d90cd331881720be0e61ab93460.tar.xz
samba-36c2a3820faa1d90cd331881720be0e61ab93460.zip
Readd the 2.2 --with-ldapsam paramaters so as to allow a smooth upgrade path to
a 3.0 based PDC. Change defaults to use SSL, so that this also matches. Andrew Bartlett
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 5221b8ec2b4..faa7a2d6fa9 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2216,6 +2216,23 @@ AC_ARG_WITH(sam,
########################################################################################
#################################################
+# check for a LDAP password database configuration backwards compatibility
+AC_MSG_CHECKING(whether to use LDAP SAM 2.2 compatible configuration)
+AC_ARG_WITH(ldapsam,
+[ --with-ldapsam Include LDAP SAM 2.2 compatible configuration (default=no)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_LDAP_SAMCONFIG)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+#################################################
# check for a TDB password database
AC_MSG_CHECKING(whether to use TDB SAM database)
AC_ARG_WITH(tdbsam,