summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-11-13 07:04:00 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-11-13 07:04:00 +0000
commit111b0405cf8c95da5c927f31e5db7fd51c590b1f (patch)
treea3295997105fbf5c2ea78d3dee8175273180902b /source/configure.in
parent57f7ab45b783f64a3f3337a893ba3ddef953c133 (diff)
downloadsamba-111b0405cf8c95da5c927f31e5db7fd51c590b1f.tar.gz
samba-111b0405cf8c95da5c927f31e5db7fd51c590b1f.tar.xz
samba-111b0405cf8c95da5c927f31e5db7fd51c590b1f.zip
Merge from HEAD
- make configure check for the location of Heimdal KRB5 on suse systems - fix libsmbclient for new global_myname()
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 16e9af4b47f..3c5f74a67e7 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1989,6 +1989,20 @@ if test x"$with_ads_support" = x"yes"; then
if test x$FOUND_KRB5 = x"no"; then
#################################################
+# see if this box has the SuSE location for the heimdal kerberos implementation
+AC_MSG_CHECKING(for /usr/include/heimdal)
+if test -d /usr/include/heimdal; then
+ CFLAGS="$CFLAGS -I/usr/heimdal/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/heimdal/include"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+fi
+
+
+if test x$FOUND_KRB5 = x"no"; then
+#################################################
# see if this box has the RedHat location for kerberos
AC_MSG_CHECKING(for /usr/kerberos)
if test -d /usr/kerberos; then