summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-06-09 00:10:26 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:23:13 -0500
commitb5cb21e951550fe836b0ef5febc037af9a7f51ec (patch)
treec251eb5f52b1d3f5c54ecc7e8192597823f780d4 /source/configure.in
parentb9d6eee5d4d0894ded88455675a470cbf04d8f45 (diff)
downloadsamba-b5cb21e951550fe836b0ef5febc037af9a7f51ec.tar.gz
samba-b5cb21e951550fe836b0ef5febc037af9a7f51ec.tar.xz
samba-b5cb21e951550fe836b0ef5febc037af9a7f51ec.zip
r23398: Support membership of >16 groups on Darwin by making sure we opt in to the
dynamic group resolution mechanism when switching UNIX credentials.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index be92a9144d5..d69a40eb900 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3100,6 +3100,21 @@ if test x"$samba_cv_USE_SETUIDX" = x"yes"; then
fi
fi
+AC_CACHE_CHECK([for the Darwin initgroups system call],
+ samba_cv_DARWIN_INITGROUPS,
+ AC_TRY_LINK([
+#include <sys/syscall.h>
+#include <unistd.h>
+ ],
+ [ syscall(SYS_initgroups, 16, NULL, NULL, 0); ],
+ samba_cv_DARWIN_INITGROUPS=yes,
+ samba_cv_DARWIN_INITGROUPS=no)
+)
+
+if test x"$samba_cv_DARWIN_INITGROUPS" = x"yes" ; then
+ AC_DEFINE(HAVE_DARWIN_INITGROUPS, 1,
+ [Whether to use the Darwin-specific initgroups system call])
+fi
AC_CACHE_CHECK([for working mmap],samba_cv_HAVE_MMAP,[
AC_TRY_RUN([#include "${srcdir-.}/tests/shared_mmap.c"],