summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2006-01-05 11:35:29 +0000
committerVolker Lendecke <vlendec@samba.org>2006-01-05 11:35:29 +0000
commit2d492971650fbb936291f34715a0b7fe6f95d0a9 (patch)
treef06be530d10a18f9653bf26df9fab80d68898422 /source/configure.in
parent9d74e1799fffa7a50cabca03683c48ae817afdef (diff)
downloadsamba-2d492971650fbb936291f34715a0b7fe6f95d0a9.tar.gz
samba-2d492971650fbb936291f34715a0b7fe6f95d0a9.tar.xz
samba-2d492971650fbb936291f34715a0b7fe6f95d0a9.zip
r12721: GPFS 2.4 on Linux will contain some windows semantics, ie share modes and
oplocks across the cluster. Adapt Samba to it. The gpfs API is called via libgpfs.so. This code is written with dlopen(), so that you can compile on a system with gpfs installed and later on run on systems without gpfs available. So to actually make Samba call gpfs share mode calls you need to compile with gpfs.h and libgpfs.so around and set 'gpfs share = yes' on the shares you export from GPFS. Volker
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index ec1bdacad84..2b1f4d691f9 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1159,6 +1159,19 @@ AC_CHECK_FUNCS(setbuffer shmget shm_open backtrace_symbols)
AC_CHECK_HEADERS(libexc.h)
AC_CHECK_LIB(exc, trace_back_stack)
+echo -n "checking for GPFS 2.4 libs... "
+save_LIBS="$LIBS"
+LIBS="$LIBS -lgpfs"
+AC_TRY_LINK([#include <gpfs.h>],
+ [gpfs_set_share(0,GPFS_SHARE_READ,GPFS_DENY_NONE)],
+ samba_cv_HAVE_GPFS_SET_SHARE=yes,
+ samba_cv_HAVE_GPFS_SET_SHARE=no)
+echo $samba_cv_HAVE_GPFS_SET_SHARE
+if test x"$samba_cv_HAVE_GPFS_SET_SHARE" = x"yes"; then
+ AC_DEFINE(HAVE_GPFS_SET_SHARE,1,[Whether GPFS 2.4 libs are available])
+fi
+LIBS="$save_LIBS"
+
# syscall() is needed for smbwrapper.
AC_CHECK_FUNCS(syscall)