summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2004-09-21 01:37:34 +0000
committerTim Potter <tpot@samba.org>2004-09-21 01:37:34 +0000
commit9a78126bedccd444d3f96348beee31b8f3042d75 (patch)
tree8aada7c19d604fe7323c514bdc2b57761c585355 /source/configure.in
parentaa411dd7f38eaea8c221935c7dcffdfa6158bd45 (diff)
downloadsamba-9a78126bedccd444d3f96348beee31b8f3042d75.tar.gz
samba-9a78126bedccd444d3f96348beee31b8f3042d75.tar.xz
samba-9a78126bedccd444d3f96348beee31b8f3042d75.zip
r2453: I think this is the last lot of fixes to get shared libraries working on
HPUX. This is Richard Allen's suggestion to get HPUX to use cc instead of ld. Also he added some missing $(DYNEXP) on link lines and removed the definition of $(LINK) as it is no longer used in the Makefile.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/configure.in b/source/configure.in
index a2c0d981fd4..69152d8fc8f 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1214,9 +1214,9 @@ if test "$enable_shared" = "yes"; then
# Use special PIC flags for the native HP-UX compiler.
if test $ac_cv_prog_cc_Ae = yes; then
BLDSHARED="true"
- SHLD="/usr/bin/ld"
- LDSHFLAGS="-B symbolic -b -z"
- SONAMEFLAG="+h "
+ SHLD="cc"
+ LDSHFLAGS="-b -Wl,-B,symbolic,-b,-z"
+ SONAMEFLAG="-Wl,+h "
PICFLAGS="+z"
elif test "${GCC}" = "yes"; then
PICFLAGS="-fPIC"