summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2001-07-23 07:18:03 +0000
committerRichard Sharpe <sharpe@samba.org>2001-07-23 07:18:03 +0000
commitf38b5ba1946327714e1c9cc3ff91b0063906bd9c (patch)
treebe8d7aab1f524c60eeb34ebaddac4372f63e5d0b /source/configure.in
parent96bd7bdd0b4f6572c678c7b1bc5ffe733e632fda (diff)
downloadsamba-f38b5ba1946327714e1c9cc3ff91b0063906bd9c.tar.gz
samba-f38b5ba1946327714e1c9cc3ff91b0063906bd9c.tar.xz
samba-f38b5ba1946327714e1c9cc3ff91b0063906bd9c.zip
OK, I think I have fscking IRIX figured out for building PIC code.
You have to check which fsking compiler is used and do different things!
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 8b147c49e01..44b2533294a 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -641,7 +641,11 @@ case "$host_os" in
ATTEMPT_WRAP32_BUILD=yes
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
- PICFLAG="-KPIC"
+ if test "${ac_cv_prog_CC}" = "gcc"; then
+ PICFLAG="-fPIC"
+ else
+ PICFLAG="-KPIC"
+ fi
;;
*aix*) AC_DEFINE(AIX)
BLDSHARED="true"