summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2001-08-23 19:06:20 +0000
committerTim Potter <tpot@samba.org>2001-08-23 19:06:20 +0000
commit2dbb41a7b88e7fad63579111aaab4a1cd28c54d5 (patch)
treedb871de0f3ec3655e0235cebc31d160098e4514a /source/configure.in
parentbfce4ba7b6db261d981a60a7e262f2f690355f5c (diff)
downloadsamba-2dbb41a7b88e7fad63579111aaab4a1cd28c54d5.tar.gz
samba-2dbb41a7b88e7fad63579111aaab4a1cd28c54d5.tar.xz
samba-2dbb41a7b88e7fad63579111aaab4a1cd28c54d5.zip
Fixed detection of CUPS. We need to check for the presence of the cups
header files as well as libcups.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 88e2349d9a4..85d73fa815f 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -306,9 +306,23 @@ AC_CHECK_TYPE(offset_t,loff_t)
AC_CHECK_TYPE(ssize_t, int)
AC_CHECK_TYPE(wchar_t, unsigned short)
-# we need libcups for CUPS support...
+############################################
+# for cups support we need libcups, and a handful of header files
+
AC_CHECK_LIB(cups,httpConnect)
+# I wonder if there is a nicer way of doing this?
+
+if test x"$ac_cv_lib_cups_httpConnect" = x"yes"; then
+ AC_CHECK_HEADERS(cups/cups.h cups/language.h)
+ if x"$ac_cv_header_cups_cups_h" = x"yes"; then
+ if x"$ac_cv_header_cups_language_h" = x"yes"; then
+ AC_DEFINE(HAVE_CUPS)
+ fi
+ fi
+fi
+
+############################################
# we need libdl for PAM and the new VFS code
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])