summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-03 02:25:28 +0000
committerJeremy Allison <jra@samba.org>1998-11-03 02:25:28 +0000
commitf09ab9b52251087a58af92ec753537ca34a970fc (patch)
tree8f94f9137e344849403eb1733133a09019caf8cc /source/configure.in
parentf55cc67dadc3c2ea3076755e308e3467083f1001 (diff)
downloadsamba-f09ab9b52251087a58af92ec753537ca34a970fc.tar.gz
samba-f09ab9b52251087a58af92ec753537ca34a970fc.tar.xz
samba-f09ab9b52251087a58af92ec753537ca34a970fc.zip
Makefile.in configure configure.in include/proto.h smbd/noquotas.c smbd/quotas.c:
Added quotas patch for autoconf from Dejan Ilic <svedja@lysator.liu.se>. printing/printing.c: Filenames with spaces patch from Allan Bjorklund <allan@umich.edu> utils/nmblookup.c: Fix usage() function. smbd/reply.c: Split out the security=server and security=domain checks into check_server_security() and check_domain_security() to aid the writing of the 'hack' appliance mode invented by John Schimmel. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index cb26606a7c5..a52b02fe871 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -762,6 +762,26 @@ AC_ARG_WITH(netatalk,
AC_MSG_RESULT(no)
)
+#################################################
+# check for experimental disk-quotas support
+QUOTAOBJS=noquotas.o
+
+AC_MSG_CHECKING(whether to support disk-quotas)
+AC_ARG_WITH(quotas,
+[ --with-quotas Include experimental disk-quota support
+ --without-quotas Don't include experimental disk-quota support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ QUOTAOBJS=quotas.o
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+AC_SUBST(QUOTAOBJS)
#################################################
# these tests are taken from the GNU fileutils package