summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-10-15 19:30:12 +0000
committerJeremy Allison <jra@samba.org>1998-10-15 19:30:12 +0000
commitbdba1bcf2094d2b33dd74d3cfde61723dd7fc46b (patch)
tree3115c48259fe63d93a8b2df173603a20fbb82a05 /source/configure.in
parenta7fccd807b938cbb51002ebae8c7a48b40dbb655 (diff)
downloadsamba-bdba1bcf2094d2b33dd74d3cfde61723dd7fc46b.tar.gz
samba-bdba1bcf2094d2b33dd74d3cfde61723dd7fc46b.tar.xz
samba-bdba1bcf2094d2b33dd74d3cfde61723dd7fc46b.zip
Fixed crypt problems on IRIX with prototype.
Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source/configure.in b/source/configure.in
index dc036c6238a..155c03ec08a 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -117,7 +117,7 @@ fi
# stupid glibc has the functions but no declaration. grrrr.
AC_CACHE_CHECK([for setresuid declaration],samba_cv_have_setresuid_decl,[
- AC_TRY_COMPILE([#include <unistd.h>],[int i = setresuid],
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = (int)setresuid],
samba_cv_have_setresuid_decl=yes,samba_cv_have_setresuid_decl=no)])
if test x"$samba_cv_have_setresuid_decl" = x"yes"; then
AC_DEFINE(HAVE_SETRESUID_DECL)
@@ -125,7 +125,7 @@ fi
# stupid glibc has the functions but no declaration. grrrr.
AC_CACHE_CHECK([for crypt declaration],samba_cv_have_crypt_decl,[
- AC_TRY_COMPILE([#include <unistd.h>],[int i = crypt],
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = (int)crypt],
samba_cv_have_crypt_decl=yes,samba_cv_have_crypt_decl=no)])
if test x"$samba_cv_have_crypt_decl" = x"yes"; then
AC_DEFINE(HAVE_CRYPT_DECL)