summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-12-10 23:52:34 +0000
committerJeremy Allison <jra@samba.org>1998-12-10 23:52:34 +0000
commitbd61029e2ad2cec7751a251fccd2dbf709175fc9 (patch)
tree2de1a80e057dc126c004293642e713e3cd6fbce6 /source/configure.in
parent4f9d42ea67814387d9f3ee9c7b0a672ea000b70c (diff)
downloadsamba-bd61029e2ad2cec7751a251fccd2dbf709175fc9.tar.gz
samba-bd61029e2ad2cec7751a251fccd2dbf709175fc9.tar.xz
samba-bd61029e2ad2cec7751a251fccd2dbf709175fc9.zip
HPUX fix. This looks like a big change but isn't actually, most of the
changes are bzero -> memset as the compiler on HPUX is very picky about bzero (probably a strange define). The significant changes are in configure.in, to fix the HPUX shadow.h problem and also move the large file support to the correct place. passdb/pass_check.c: Added includes for KRB5, DCE and AFS if requested in autoconf. tests/trapdoor.c: Fix to use setresuid and setresgid if defined. The rest of the changes are bzero -> memset. Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in31
1 files changed, 21 insertions, 10 deletions
diff --git a/source/configure.in b/source/configure.in
index 0477f81b6a2..cf730e8f2bc 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -36,6 +36,14 @@ case "$host_os" in
if test $ac_cv_prog_cc_Ae = yes; then
CPPFLAGS="$CPPFLAGS -Ae"
fi
+#
+# Defines needed for HPUX large file support..
+#
+ case `uname =r` in
+ *10*|*11*)
+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
+ ;;
+ esac
;;
#
# AIX4.x doesn't even admit to having large
@@ -56,16 +64,6 @@ case "$host_os" in
esac
;;
#
-# Defines needed for HPUX large file support..
-#
- *hpux*)
- case `uname =r` in
- *10*|*11*)
- CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
- ;;
- esac
- ;;
-#
# Tests needed for SINIX large file support.
#
*sysv4*)
@@ -106,6 +104,19 @@ AC_CHECK_HEADERS(sys/wait.h sys/resource.h sys/ioctl.h sys/mode.h)
AC_CHECK_HEADERS(sys/filio.h string.h strings.h stdlib.h sys/socket.h)
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h)
AC_CHECK_HEADERS(sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h sys/sockio.h)
+#
+# HPUX has a bug in that including shadow.h causes a re-definition of MAXINT.
+# This causes configure to fail to detect it. Check for shadow separately on HPUX.
+#
+case "$host_os" in
+ *hpux*)
+ AC_TRY_COMPILE([#include <shadow.h>],[struct spwd testme],
+ ac_cv_header_shadow_h=yes,ac_cv_header_shadow_h=no)
+ if test x"$ac_cv_header_shadow_h" = x"yes"; then
+ AC_DEFINE(HAVE_SHADOW_H)
+ fi
+ ;;
+esac
AC_CHECK_HEADERS(shadow.h netinet/tcp.h sys/security.h security/pam_appl.h)
AC_CHECK_HEADERS(stropts.h poll.h readline.h history.h readline/readline.h)
AC_CHECK_HEADERS(readline/history.h sys/capability.h syscall.h sys/syscall.h)